Auteur Sujet: Krfb : Écran noir/illisible  (Lu 6510 fois)

Hors ligne blueduck

  • Posteur
  • **
  • Messages: 1
Krfb : Écran noir/illisible
« le: 28 janvier 2009, 11:21:55 »
Bonjour,

J'essaie de contrôler mon PC perso (Kubuntu 8.10) depuis mon PC pro (WinXP Pro SP2). Le PC perso est relié en Ethernet à mon routeur (Freebox v5), le PC perso également (mais Livebox pro).

J'ai configuré Krfb sur Kubuntu pour qu'il accepte les connexions non-invitées avec mot de passe ; le port 5900 est ouvert sur la Freebox et correctement redirigé. Pas de pare-feu (oui, c'est mal, mais quand ça marchera je ferai passer tout ça à travers OpenVPN ;) ).

J'utilise sur le PC pro VNC Navigator ou TightVNC : le résultat est le même sur l'un ou l'autre.

Dans un premier temps, à la connexion, je passais l'identification par mot de passe mais n'obtenais qu'un écran noir.
Après un coup d'oeil dans la FAQ, j'ai trouvé ce topic : http://forum.ultravnc.fr/index.php/topic,338.0.html. J'ai donc baissé le MTU du PC pro à 1492 : toujours l'écran noir. Toutefois, les événements de la souris étaient bien transmis vu le bazar qu'il y avait sur mon Bureau quand je suis rentré le soir ! J'ai alors également baissé à 1492 le MTU du PC perso.
Du coup, ce matin, il y a du mieux : au lieu d'un écran complètement noir, j'ai un écran majoritairement noir :P Le quart supérieur et le quart gauche sont affichés mais sont totalement illisibles, car striés de lignes horizontales (ça fait un peu penser à un serveur X mal configuré).

J'ai essayé de modifier les options du client (indifféremment VNC Navigator ou TightVNC) : augmenter/diminuer la compression, la profondeur de couleurs, la bande-passante... rien n'y fait :(

Quelqu'un a-t-il déjà rencontré ce problème ? Faut-il encore baisser le MTU alors que les paquets ne sont plus fragmentés ? De combien ? Quelqu'un aurait-il une solution ?

Merci d'avance,

Blue Duck

Hors ligne pat12

  • Jr. Member
  • ***
  • Messages: 56
Re : Krfb : Écran noir/illisible
« Réponse #1 le: 11 février 2009, 14:01:06 »