Auteur Sujet: Plantage sur "Negociate Protocol Version"  (Lu 18431 fois)

Hors ligne kikon

  • Posteur
  • **
  • Messages: 3
Re : Plantage sur "Negociate Protocol Version"
« Réponse #15 le: 08 octobre 2006, 14:56:23 »
bonjour,
j'ai désisntallé la mise à jour xp kb 925486 sur deux machines sur trois rien ne change cela fonctionne parfois puis  négotiation etc j' ai 2 antivirus différent norton  et avast je vois un nouveau post à ce sujet sur ce forum
 je  mets entre 5 à 30mn pour accéder a un pc et tout fonctionnait nikel de puis plus d' un an 
j'ai désinstallé complètement la version 101 et installé la 102 même problème

 mon adresse no-ip fonctionne car je visionne mes caméras mais vnc se plante
 voila si cela peut aider
a+

Hors ligne zerunner

  • Posteur
  • **
  • Messages: 1
Re : Plantage sur "Negociate Protocol Version"
« Réponse #16 le: 09 octobre 2006, 10:12:02 »
Bonjour, depuis deux semaines, nous rencontrons des soucis avec VNC. Nous avons "Negotiate protocol..". Ensuite, après deux ou trois essais infructueux, nous obtenons le message "failed to connect to server"!

Le "Negociate Protocol..." fonctionne parfois apres quelques heures.

Pour info:
OS : Windows XP Pro SP2 coté serveur et client,
Antivirus : Trend Officescan des deux cotés,
MAJ OS : Activées mais pas toujours faites,
Firewall : SP2,
Client P2P : Aucuns,
Premier signe probleme : 2 semaines,
Date installation VNC : Fevrier 2006,
Version VNC : 1.0.1,
Type de connexion : Ethernet coté client et ADSL avec modem USB coté serveur, nous passons à travers un VPN pour la prise en main à distance. Meme sans VPN, VNC est inaccessible aussi.
Résolution provisoire : redémarrage du poste serveur.

En esperant trouver une solution rapidement!

Merci, @bientot

Zerunner.

Hors ligne UltraSam

  • Super-modérateur
  • *****
  • Messages: 33
Re : Plantage sur "Negociate Protocol Version"
« Réponse #17 le: 09 octobre 2006, 11:15:57 »
Bon nous sommes sur une piste:

Depuis 1 mois, les scans massifs sur le port 5900 venant d'internet ont du se multiplier.

Nous avons identifié une faiblesse dans le serveur qui fait qu'un premier paquet trop gros peut "indisposer" WinVNC et faire qu'il refuse les connexions pendant un certain temps. Mais sans le crasher vraiment.
Il y a plusieurs manières de provoquer ce phénomène, que je ne détaillerai pas ici.

La faiblesse est à priori corrigée.
Je vérifie et complète si besoin le fix ce soir
Un patch sera mis en ligne dés que possible.

En attendant:
- vous pouvez utiliser le plugin DSM (à priori on a a pas ce probleme avec , mais ça reste à confirmer)
- utilisez un autre port que le port 5900 (entre 800 et 1000) ce qui devrait calmer les éventuels scanners et autres petits malins
« Modifié: 09 octobre 2006, 13:16:16 par UltraSam »

Hors ligne Sparad0x

  • Administrateur
  • *****
  • Messages: 496
Re : Plantage sur "Negociate Protocol Version"
« Réponse #18 le: 09 octobre 2006, 15:52:32 »
Merci pour le temps que tu passes sur UltraVNC, UltraSam!
J'espère que ce sera bien la cause de ce problème qui semble toucher de plus en plus de monde...

Keep Fun ;)

Sparad0x

Hors ligne redge

  • Modérateur
  • *****
  • Messages: 403
Re : Plantage sur "Negociate Protocol Version"
« Réponse #19 le: 10 octobre 2006, 22:46:33 »
un utilisateru a eu le meme symptome avec la RC18 sur le forum.ultravnc.info qui a fonctionné depuis des lustres, donc cela conforme le diagnostic de UltraSam :-)
http://forum.ultravnc.info/viewtopic.php?t=7950

Hors ligne foufi

  • Posteur
  • **
  • Messages: 4
Re : Plantage sur "Negociate Protocol Version"
« Réponse #20 le: 14 février 2007, 11:19:11 »
euh je reviens sur ce probleme car j'ai exactement ce genre de soucis depuis plusieurs semaines maintenant ca a donné quoi ?

MErci

Hors ligne PoS

  • Posteur
  • **
  • Messages: 7
Re : Plantage sur "Negociate Protocol Version"
« Réponse #21 le: 27 février 2007, 16:14:45 »
J'ai exactement le même problème que vous !

PC1:
Win XP Familiale SP2
MàJ actives
IP: 192.168.1.5
Ultr@ VNC 1.0.2 (installation de base et installation suivant le tutoriel du site)

PC2:
Win XP Familiale SP2
MàJ actives
IP: 192.168.1.6
Ultr@ VNC 1.0.2 (installation de base et installation suivant le tutoriel du site)


Voila voila :)

Sinon j'ai testé Real VNC et j'ai le MÊME problème :) il faut redémarré le serveur a chaque fois

Quoi d'autre ? ...
A oui, j'ai remarqué que quand on quittait le serveur (clique droit quitter), qu'une entrée existait toujours dans les taches (winvnc.exe) et de même pour le client


Pour palier au problème je propose de rajouter dans les options/
Dans "Dernier client se Déconnecte"
Rajoutez l'option: "Redémarrer le Serveur"

Je pense que c'est un bon système D


J'espère avoir des nouvelles bientôt. Ciao à tous